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4 Simulink

4.1 Quick introduction

General information
Simulink is an extension of Matlab software for simulating dynamic systems. This is a screen
oriented program, i.e. all tasks can be realized by mouse driven commands within proper windows.
A typical Simulink session has two phases: model definition and model analysis. Defining model
is just drawing a block diagram from blocks of the Simulink Blocks Library. Analyzing model is
simulating, trimming or linearizing. It can be done either in the Simulink environment or in the
Matlab environment.

Simulink session

Start & Quit. To start a Simulink session enter simulink in the Matlab environment. To
quit Simulink click on Exit in the File menus of the all Simulink windows.

Model definition. Select New... from the File menu of the Simulink window. It opens a
blank window, in which the model will be constructed. The default name of the window is Untitled.
Open one or more libraries and drag blocks, that you need, into the active window.
Draw lines to connect blocks in the block scheme that is corresponding to your model.
Open blocks (by double clicking) to set up their parameters. Block parameters can be any legal
Matlab expressions
Save the system by selecting Save as from the File menu of the window Untitled.

Model analysis. Suppose that defined model is saved in the sfun.m file. It is a function, from
Matlab point of view, that defines dynamics of the model. The following analysis can be done
(in the Matlab environment):
• simulation - by using one of the integration algorithms (euler, rk23, . . . ). Obtained output and
state vectors can be plotted by the plot command.
• derivation of equilibrium points (trim).
• linearization around an equilibrium point (linmod). Linearized models can be also analyzed by
other Matlab commands, f.e. from Control Toolbox.

4.2 Block diagrams

Blocks. Blocks are graphical representation of elementary dynamic systems like integrator, suma-
tor, multiplier, constant. For example, the block on Figure 1
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Figure 1:

represents the system y =
∫
u(t)dt+ C

Block scheme. It is an interconnection of blocks with singled out input and output signals (u, y),
such that an arbitrary relation
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is satisfied.

Dynamic systems modelling - examples

• Dynamical system:

ẏ + 5y = 2u (1)

Remark: Make a block diagram realization for the following representation of (1)

ẏ = −5y + 2u (2)

Block scheme: See Figure 2
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Figure 2:

• Dynamical system:

y(3) − y(2) − y(1) − y = u (3)

Remark: Introduce the auxiliary variables x1 = y, x2 = y(1), x3 = y(2) and write (3)
as a set of first order difference equations:

ẋ1 = x2 (4)
ẋ2 = x3 (5)
ẋ3 = x3 + x2 + x1 + u (6)
y = x1 (7)

Write block schemas for each equation and then glue all together.
Block scheme: See Figure 3.
( Note that in case of linear systems the more eficient way of defining of a system is to
use one of the blocks: State-Space,Transfer Fcn,Zero-Pole.)

• Dynamical system:

ẋ1 = x2 (8)
ẋ2 = (x1 + x2 + 1)2 + u (9)
y = x1 (10)

Block scheme: See Figure 4
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(u(1)+u(2)+1)^2
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4.3 Quick reference

OBJECT MANIPULATION

Cursor modes
Cursor Shape Activity

ready for next action

dragging a block or line segment

dragging a line vertex

drawing a line

reasizing a block

dragging a bounding box in the window background

double-clicking on a block (until the block is open)

Selecting objects
• To select an object or an insertion point, click on it.
• To select more than one object, hold down the Shift key and use left mouse button to select
the objects.
Alternatively use a bounding box. Press and hold the mouse button if the cursor is not pointing
to any object. The starting corner of the box is fixed while the opposite corner can be dragged
to another location within the window. When the mouse button is released, all blocks at least
partially enclosed and all lines fully enclosed by the bounding box are selected.
• To select all objects in the active window, choose Select All from the Edit menu.

Manipulating Blocks
mowing: Position the pointer on the Block to be moved or on the blocks selected with a bounding
box, press and hold down the left mouse button, drag the pointer to target location, and release
the mouse button.
copying: Using the right mouse button apply the procedure for moving.
deleting blocks: Select the block(s) to be removed and press the Delete key. Alternatively,
choose Clear or Cut in the Edit menu.
editing block names: Block names can be edited in one of three ways:
• Select the box in which the name is displayed, and insert the new name.
• Select an insertion point in the name, and insert new text.
• Drag the mouse to select a range of text to replace, and enter the new text.
opening blocks: Click double on it.
changing styles: Rotation: use Flip and Rotate from Options menu or Orientation from the
Style menu.

Manipulating lines
drawing lines between blocks:
• To direct the output of one block to the input of another, select the output port, hold down the
left mouse button, and drag the pointer to the desired input port. Release the mouse button.
• To draw ad unconnected line segment, select a block’s input or output port, move the mouse,
and then release the mouse button while the pointer is on an empty area of the diagram.
deleting lines:
• Select the line(s) to be removed and press the Delete key.
• (alternatively) Choose Clear or Cut from the Edit menu.
moving, segmenting, and adding lines:
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• To move an entire line segment or a corner of two line segments, position the pointer on the line
or corner, and drag it to the desired location by moving the mouse ( )
• To divide a line into two segments, leaving the ends of the line in their original locations, position
the pointer anywhere on the existing line, hold down both mouse buttons, and drag the mouse to
the desired location. ( )
• To add a line from the middle of another line position the pointer on the line, hold down the
right mouse button and drag the pointer to the desired location by moving the mouse.

SIMULINK MENUS

File menu

New Create a new system.
Open Select a system to load from disk.
Close Remove the system from memory.
Save Write a system to a file, using the same filename.
Print Print a block diagram.
Printer Setup Set up page.
Exit Quit.

Edit Menu

Cut Move the selected objects to the Clipboard from the active window.
Copy Copy the selected objects to the Clipboard,

leaving them intact in their original notation.
Paste Copy the contents of the Clipboard to the selected insertion location.
Clear Delete the selected objects.
Select All Select all objects in the active window.

Options Menu

Group Group selected objects together to create a new subsystem block.
Ungroup Ungroup a subsystem block, placing the individual

blocks in the main parent diagram.
Mask1 Provide an interface for a block.
Flip Horizontal Rotate orientation of selected blocks 180 degrees.
Rotate Rotate orientation of selected blocks 90 degrees.

Simulation Menu

Start Start simulating the model in the active window;
simulation when that is running.

Restart Restart the current simulation.
Pause Pause the current simulation; continue the simulation

from where it was paused.
Parameters the simulation parameters. parameters displays a dialog box

in which you can specify the integration algorithm and the other simulation
parameters to be used in the current simulation.
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Style Menu

Drop Shadows Toggle drop shadows on and off of selected blocks.
Orientation Set the orientation of selected blocks.
Title Choose the position and visibility of the names of selected blocks.
Background Color the background color of selected blocks.
Screen Color Choose screen color.

BLOCKS

Parameter dialog box
Most blocks provide a parameter dialog box when opened (double-clicked). These dialog boxes
have the number of elements in common:
• There is a region containing editable text fields, one for each parameter, that can be set for this
type of block. Any valid Matlab expression can be entered in these fields.
• Each field is labelled with the name of the parameter and shows the default or current value of
that parameter if any.
• In the upper right corner of the dialog box is a column of three buttons labeled OK, Cancel,
Help

OK - Closes the dialog box setting the current field values
Cancel - Reverts all of the parameter values back to their values at the time

was opened, loosing any changes made since the window was opened.
Help - Displays an explanation of the block’s behavior.

Block libraries
Sources

Clock - Provide and display system time.
Constant - Inject a constant value.
From File - Read data from file.
From Workspace - Read data from a matrix.
Signal Generator - Various waveforms.
Sine Wave - Generate a sine wave.
Step Fcn - Random noise.

Sinks

Scope - Display signals during simulation.
To File - Write data to a file.
To Workspace - Write data to a matrix.

Discrete

Discrete State-Space - Discrete state-space system.
Discrete Transfer Fcn - Discrete transfer function.
Discrete Zero-Pole - Discrete system as zeros, poles and gain.
Filter - Implement IIR and FIR filters.
Unit Delay - Delay signal for one sample period.

Linear
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Derivative - Output the time derivative of the input.
Gain - Multiply input by a constant.
Integrator - Integrate a signal.
State-Space - Implement a linear state space system.
Sum - Sum outputs together.
Transfer Fcn - Implement a linear transfer function.
Zero-Pole - Specify a linear system as zeros, poles and gain.

Nonlinear

Abs - Output the absolute value of input.
Backlash - Model hysteresis.
Dead Zone - Provide a region of zero output.
Fcn - General purpose function of the input.
Look Up Table - Perform piecewise linear mapping.
MATLAB Fcn - Apply Matlab function to the input.
Product - Multiply inputs together.
Rate Limiter - Limit the rate of change of a signal.
Relay - Switch output between two values.
Saturation - Limit excursion of signal.
S-function - Make an S-function into a block.
Switch - Switch between two inputs.
Transport Delay - Delay the input by a given amount of time.

Connections

Demux - Separate vector signal into scalar signals.
Inport - Provide link to an external input.
Mux - Group scalar lines into a vector line.
Outport - Provide link to an external output.

ANALYSIS COMMANDS
Analysis commands are Matlab commands which operate on dynamical systems representations
in S-files.

Integration algorithm for simulation

Purpose: Integrate a system of ordinary differential equations.

Synopsis: [t,x,y] = linsim(’ sfun ’, tfinal , x0 , options, u)
[t,x,y] = euler(’ sfun ’, tfinal , x0 , options, u)
[t,x,y] = rk23(’ sfun ’, tfinal , x0 , options, u)
[t,x,y] = rk45(’ sfun ’, tfinal , x0 , options, u)
[t,x,y] = adams(’ sfun ’, tfinal , x0 , options, u)
[t,x,y] = gear(’ sfun ’, tfinal , x0 , options, u)

Description: [t,x,y] - [integration time points, state trajectories, output trajectories]
tfinal = [tb,te] - integration interval. If tb = 0 then tfinal = te.
x0 - initial state (constants on integrators) at time instant tb.
This overrides initial conditions
which may have been set in the block diagram.
options - set [].
u - external input to the system. It must be a matrix with two columns: u=[ t , u(t) ].
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t is a time vector on which u is defined, f.e. t=(0:0.1:10).

Linearization

Purpose: Extract the linear-state-space model of a system around the operating point.

Synopsis: [A,B,C,D] = linmmod(’ sfun ’,x,u)

Description: A,B,C,D - matrices of the linearized model
x,u - state vector and input vector - the operating point at which
the linear model is to be extracted

Equilibrium point

Purpose: Determine steady state parameters that satisfy input, output and state conditions.

Synopsis: [x,u,y] = trim(’ sfun ’,x0,u0,y0)

Description: [x,u,y] - equilibrium point
x0,u0,y0 - starting guesses for x,u,y respectively.


